Electronic Components Datasheet Search
  English  ▼
ALLDATASHEET.NET

X  



RFC Distributor

DistributorPart #ManufacturerDescriptionPriceQty.
BuyNow

Verical
RFC02MM2STR

ROHM Semiconductor Diode Switching Si 200V 0.5A 2-Pin PMDU T/R
RoHS : Exempt
562 : $0.4998
5,330
RFC02MM2STFTR

ROHM Semiconductor Diode Switching Si 200V 0.5A 2-Pin PMDU T/R Automotive AEC-Q101
RoHS : Exempt
2,500 : $0.0922
1,000 : $0.095
770 : $0.0982
3,000
RFCYP-19-Z

JST Manufacturing RFCYP-19-Z
250 : $0.6035
130 : $0.6287
440
RFCP-36W0-E

JST Manufacturing RFCP-36W0-E
250 : $0.5956
132 : $0.6205
400
RFCP-15S3-SRL-K

JST Manufacturing RFCP-15S3-SRL-K
250 : $1.3088
100 : $1.3635
60 : $1.4274
320
RFCYP-17-Z

JST Manufacturing RFCYP-17-Z
250 : $0.6818
115 : $0.7103
305
RFC02MM2STFTR

ROHM Semiconductor Diode Switching Si 200V 0.5A 2-Pin PMDU T/R Automotive AEC-Q101
RoHS : Exempt
277 : $0.2837
277
RFCP-24W6-E.

JST Manufacturing RFCP-24W6-E.
100 : $2.0574
50 : $2.1296
35 : $2.214
200
RFCYP-19-Z

JST Manufacturing RFCYP-19-Z
130 : $0.6287
185
RFC02MM2STR

ROHM Semiconductor Diode Switching Si 200V 0.5A 2-Pin PMDU T/R
RoHS : Exempt
154 : $0.5307
154
RFCP-36W6-E.

JST Manufacturing RFCP-36W6-E.
100 : $0.8998
91 : $0.9419
116
RFC02MM2STR

ROHM Semiconductor Diode Switching Si 200V 0.5A 2-Pin PMDU T/R
RoHS : Exempt
22 : $0.0747
40
RFC02MM2STFTR

ROHM Semiconductor Diode Switching Si 200V 0.5A 2-Pin PMDU T/R Automotive AEC-Q101
RoHS : Exempt
18 : $0.0896
32
RFC-2216

Quest Technology International Inc RFC-2216
2 : $55.412
5
RF CATV KIT

Rigol Technologies Kit Includes 50 Ω to 75 Ω Adaptor (2pcs)
RoHS : Compliant
1 : $419.0
5

Avnet Americas
228ADS1ARFCRE

CTS Corporation - Trays (Alt: 228ADS1ARFCRE)
RoHS : Compliant
40,000 : $1.519
20,000 : $1.52675
10,000 : $1.5345
5,000 : $1.54225
1,000 : $1.55875
0
228ADS2ARFCAA

CTS Corporation - Trays (Alt: 228ADS2ARFCAA)
RoHS : Compliant
40,000 : $1.323
20,000 : $1.32975
10,000 : $1.3365
5,000 : $1.34325
1,000 : $1.35
0
228ADS2ARFCMBC

CTS Corporation - Trays (Alt: 228ADS2ARFCMBC)
RoHS : Compliant
40,000 : $1.323
20,000 : $1.32975
10,000 : $1.3365
5,000 : $1.34325
1,000 : $1.35
0
228ADVARFCBBA

CTS Corporation - Trays (Alt: 228ADVARFCBBA)
RoHS : Compliant
40,000 : $1.2642
20,000 : $1.27065
10,000 : $1.2771
5,000 : $1.28355
1,000 : $1.29
0
228ADVARFCMSC

CTS Corporation - Trays (Alt: 228ADVARFCMSC)
RoHS : Compliant
40,000 : $1.2642
20,000 : $1.27065
10,000 : $1.2771
5,000 : $1.28355
1,000 : $1.29
0
228CMVARFCRBR

CTS Corporation - Tape and Reel (Alt: 228CMVARFCRBR)
RoHS : Compliant
43,200 : $1.47
21,600 : $1.4775
10,800 : $1.485
5,400 : $1.4925
1,350 : $1.51625
0
MFM-002RFC-011

Amphenol Corporation - Bulk (Alt: MFM002RFC011)
RoHS : Not Compliant
0
CRFC-1256/60-A

Omega Engineering HIGH TEMPERATURE, LOW MASS, VACUUM FORMED CERAMIC RADIANT FULL CYLINDER HEATERS - Bulk (Alt: CRFC-1256/60-A)
RoHS : Not Compliant
1 : $395.08
0
H4P18RFCA

TE Connectivity - Boxed Product (Development Kits) (Alt: 1879621-7)
RoHS : Compliant
50,000 : $0.44721
25,000 : $0.45714
10,000 : $0.50527
5,000 : $0.54514
500 : $0.57857
0
H830RFCA

TE Connectivity - Boxed Product (Development Kits) (Alt: 1-1879625-2)
RoHS : Compliant
50,000 : $0.33677
25,000 : $0.34424
10,000 : $0.38049
5,000 : $0.41051
500 : $0.43568
0
228ADS1ARFCMBB

CTS Corporation - Trays (Alt: 228ADS1ARFCMBB)
RoHS : Compliant
40,000 : $1.519
20,000 : $1.52675
10,000 : $1.5345
5,000 : $1.54225
1,000 : $1.55875
0
228ADVARFCRC

CTS Corporation - Trays (Alt: 228ADVARFCRC)
RoHS : Compliant
40,000 : $1.2642
20,000 : $1.27065
10,000 : $1.2771
5,000 : $1.28355
1,000 : $1.29
0
228AMVARFCRBR

CTS Corporation - Trays (Alt: 228AMVARFCRBR)
RoHS : Compliant
43,200 : $1.1466
21,600 : $1.15245
10,800 : $1.1583
5,400 : $1.16415
1,350 : $1.17625
0
228CDVARFCMBB

CTS Corporation - Trays (Alt: 228CDVARFCMBB)
RoHS : Compliant
40,000 : $1.4798
20,000 : $1.48735
10,000 : $1.4949
5,000 : $1.50245
1,000 : $1.51625
0
228CMVARFCRDR

CTS Corporation - Tape and Reel (Alt: 228CMVARFCRDR)
RoHS : Compliant
43,200 : $1.47
21,600 : $1.4775
10,800 : $1.485
5,400 : $1.4925
1,350 : $1.51625
0

Mouser Electronics
RFC02MM2STFTR

ROHM Semiconductor Rectifiers 200V VR 0.5A IO SOD-123FL; PMDU
RoHS : Compliant
1 : $2.79
10 : $1.38
100 : $1.24
500 : $0.992
1,000 : $0.973
3,000 : $0.859
5,401
RFCT-SMA-CAP-GS-1

Global Connector Technology RF Connector Accessories SMA Cap without chain IP67
RoHS : Compliant
1 : $4.49
10 : $3.61
50 : $3.43
100 : $3.26
250 : $3.06
500 : $2.91
1,000 : $2.68
2,500 : $2.51
769
RFCT-TNC-CAP-GS-2

Global Connector Technology RF Connector Accessories TNC Cap with chain IP67
RoHS : Compliant
1 : $5.01
10 : $4.26
25 : $4.0
50 : $3.81
100 : $3.63
250 : $3.39
500 : $3.23
1,000 : $3.07
2,500 : $2.88
572
RFCT-SMA-CAP-GS-7

Global Connector Technology RF Connector Accessories SMA Cap without chain IP67, Nickel-plated Brass
RoHS : Compliant
1 : $3.74
10 : $3.18
25 : $2.84
100 : $2.71
250 : $2.53
500 : $2.41
1,000 : $2.28
2,500 : $2.14
557
RFCT-N-CAP-GS-1

Global Connector Technology RF Connector Accessories N Cap with chain IP67
RoHS : Compliant
1 : $5.77
10 : $4.91
25 : $4.6
50 : $4.37
100 : $4.16
250 : $3.9
500 : $3.71
1,000 : $3.45
453
RFCT-SMA-CAP-GS-5

Global Connector Technology RF Connector Accessories SMA Cap without chain IP67 Stainless steel
RoHS : Compliant
1 : $7.61
10 : $6.47
25 : $6.06
50 : $5.78
100 : $5.5
250 : $5.16
500 : $4.9
1,000 : $4.67
448
RFC0807B-334KE

Coilcraft Inc Power Inductors - Leaded 330uH UnShld 10% 720mA 1.05ohms
RoHS : Compliant
1 : $1.09
10 : $0.917
25 : $0.833
100 : $0.651
300 : $0.6
600 : $0.567
1,050 : $0.523
2,550 : $0.5
5,100 : $0.484
241
RFCT-BNC-CAP-GS-3

Global Connector Technology RF Connector Accessories BNC Cap without chain
RoHS : Compliant
1 : $4.72
10 : $4.29
25 : $4.07
100 : $3.78
250 : $2.92
1,000 : $2.81
2,500 : $2.71
229
RFC0807B-104KE

Coilcraft Inc Power Inductors - Leaded 100uH UnShld 10% 1.25A 355mOhms
RoHS : Compliant
1 : $1.09
10 : $0.917
25 : $0.833
100 : $0.651
300 : $0.6
600 : $0.567
1,050 : $0.523
2,550 : $0.5
5,100 : $0.484
118
RFCT-BNC-CAP-GS-2

Global Connector Technology RF Connector Accessories BNC Cap with chain
RoHS : Compliant
1 : $6.21
10 : $5.65
25 : $5.36
50 : $5.23
100 : $4.98
250 : $3.75
1,000 : $3.67
97
RFC0807B-185KE

Coilcraft Inc Power Inductors - Leaded 1.8 mH UnShld 10% 300mA 5.05ohms
RoHS : Compliant
1 : $1.09
10 : $0.917
25 : $0.833
100 : $0.651
300 : $0.6
600 : $0.567
1,050 : $0.523
2,550 : $0.5
5,100 : $0.484
76
RFC0807B-275KE

Coilcraft Inc Power Inductors - Leaded 2.7 mH UnShld 10% 240mA 8ohms
RoHS : Compliant
1 : $1.09
10 : $0.917
25 : $0.833
100 : $0.651
300 : $0.6
600 : $0.567
1,050 : $0.523
2,550 : $0.5
5,100 : $0.484
52
RFC0807B-564KE

Coilcraft Inc Power Inductors - Leaded 560uH UnShld 10% 520mA 1.7ohms
RoHS : Compliant
1 : $1.09
10 : $0.917
25 : $0.833
100 : $0.651
300 : $0.6
600 : $0.567
1,050 : $0.523
2,550 : $0.5
5,100 : $0.484
14
2700784

Phoenix Contact Programmable Logic Controllers - PLCs RFC 460R PN 3TX
1 : $11,319.97
0
2916794

Phoenix Contact Programmable Logic Controllers - PLCs RFC 470S PN 3TX
1 : $7,943.69
0

Arrow Electronics
RFC02MM2STR

ROHM Semiconductor Diode Switching Si 200V 0.5A 2-Pin PMDU T/R
RoHS : Exempt
50 : $0.2197
10 : $0.2812
1 : $0.4557
40
RFC02MM2STFTR

ROHM Semiconductor Diode Switching Si 200V 0.5A 2-Pin PMDU T/R Automotive AEC-Q101
RoHS : Exempt
9,000 : $0.7284
3,000 : $0.7722
500 : $0.9008
100 : $1.1103
50 : $1.335
10 : $1.4059
1 : $1.7841
32
RF CATV KIT

Rigol Technologies Kit Includes 50 Ω to 75 Ω Adaptor (2pcs)
RoHS : Compliant
1 : $419.0
5

Newark
MFR3-56RFC

TT Electronics Welwyn Components Res, 56R, 1%, 400Mw, Axial, Metal Film; |Tt Electronics/welwyn MFR3-56RFC
RoHS : Compliant
10 : $0.186
20 : $0.081
30 : $0.065
50 : $0.049
100 : $0.038
250 : $0.028
500 : $0.022
1,000 : $0.019
33,870
MFR3-120RFC

TT Electronics Welwyn Components Through Hole Metal Film Resistor, Mfr Se; |Tt Electronics/welwyn MFR3-120RFC
RoHS : Compliant
10 : $0.089
25 : $0.072
50 : $0.053
100 : $0.041
500 : $0.03
1,000 : $0.024
5,000 : $0.021
26,505
MFR3-120RFC

TT Electronics Welwyn Components Metal Film Resistor, 120 Ohm, 400Mw, 1%; Resistance:120Ohm; Product Range:Mfr Series; Power Rating:400Mw; Resistance Tolerance:± 1%; Resistor Case/Package:Axial Leaded; Voltage Rating:200V; Resistor Technology:Metal Film Rohs Compliant: Yes
RoHS : Compliant
1 : $0.173
10 : $0.137
25 : $0.1
50 : $0.092
100 : $0.052
500 : $0.034
1,000 : $0.031
2,500 : $0.03
24,817
MFR3-27RFC

TT Electronics Welwyn Components Res Tht, 27R, ±1%, 400Mw; |Tt Electronics/welwyn MFR3-27RFC
RoHS : Compliant
10 : $0.186
20 : $0.081
30 : $0.065
50 : $0.049
100 : $0.038
250 : $0.028
500 : $0.022
1,000 : $0.019
18,260
MFR3-560RFC

TT Electronics Welwyn Components Metal Film Resistor, 560 Ohm, 400Mw, 1%, Axial Leaded; Resistance:560Ohm; Product Range:Mfr Series; Power Rating:400Mw; Resistance Tolerance:± 1%; Resistor Case/Package:Axial Leaded; Voltage Rating:200V; Product Diameter:2Mm Rohs Compliant: Yes
RoHS : Compliant
1 : $0.13
10 : $0.069
25 : $0.057
50 : $0.046
100 : $0.032
500 : $0.025
1,000 : $0.02
2,500 : $0.017
17,825
MFR3-180RFC

TT Electronics Welwyn Components Res, 180R, 1%, 400Mw, Axial, Metal Film; |Tt Electronics/welwyn MFR3-180RFC
RoHS : Compliant
10 : $0.186
20 : $0.081
30 : $0.065
50 : $0.049
100 : $0.038
250 : $0.028
500 : $0.022
1,000 : $0.019
3,852
GRFC-7

Kitagawa Industries Co Ltd Ferrite Core, Split, 7Mm, 45Ohm; |Kgs Kitagawa GRFC-7
RoHS : Compliant
1 : $3.6
10 : $3.25
25 : $3.03
50 : $2.82
100 : $2.55
500 : $2.34
1,000 : $2.07
2,500 : $1.94
362
ACM20-5-AC1-R-F-C

Murata Power Solutions Dpm, Ac Power, 32A, Frequency; |Murata Power Solutions ACM20-5-AC1-R-F-C
RoHS : Compliant
1 : $65.08
5 : $63.22
10 : $61.72
25 : $60.2
50 : $58.36
26
FCA-S1SR-FCSC-05M

L-com Inc Fc/Sc 9/125 Singlemode Simplex Fiber Pat; |L-Com FCA-S1SR-FCSC-05M
RoHS : Not Compliant
1 : $2.8
10 : $2.64
25 : $2.46
50 : $2.26
100 : $2.15
250 : $2.0
500 : $1.96
1,000 : $1.92
10
FCA-S2SR-FCASTU-10M

L-com Inc Fc-Apc To St-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASTU-10M
RoHS : Not Compliant
1 : $12.0
10 : $11.2
25 : $10.5
50 : $9.33
100 : $8.96
250 : $8.78
500 : $8.6
6
FCA-S2SR-FCASTU-05M

L-com Inc Fc-Apc To St-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASTU-05M
RoHS : Not Compliant
1 : $11.29
10 : $10.53
25 : $9.88
50 : $8.78
100 : $8.43
250 : $8.26
500 : $8.09
5
FCA-S2SR-FCAFCU-03M

L-com Inc Fc-Apc To Fc-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCAFCU-03M
RoHS : Not Compliant
1 : $11.05
10 : $10.32
25 : $9.67
50 : $8.6
100 : $8.25
250 : $8.09
500 : $7.92
3
FCA-S2SR-FCASCU-05M

L-com Inc Fc-Apc To Sc-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASCU-05M
RoHS : Not Compliant
1 : $12.0
10 : $11.2
25 : $10.5
50 : $9.33
100 : $8.96
250 : $8.78
500 : $8.6
1
FCA-S2SR-FCAFCA-15M

L-com Inc Fc-Apc To Fc-Apc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCAFCA-15M
RoHS : Not Compliant
1 : $21.24
5 : $19.78
10 : $18.8
25 : $17.92
50 : $16.87
100 : $15.93
1
FCA-S2SR-FCASCU-01M

L-com Inc Fc-Apc To Sc-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASCU-01M
RoHS : Not Compliant
1 : $2.4
10 : $2.26
50 : $2.11
100 : $1.94
250 : $1.85
500 : $1.71
1,000 : $1.68
2,500 : $1.64
1

RS
RFC-2216

Quest Technology International Inc CABLE ASSEMBLY, UHF PLUG X2, RG-58A/U CBL, 10FT., NON BOOTED
1 : $39.6
44
CRF-CX

ILME UK Ltd ACCESSORY, STAINLESS STEEL FEMALE CODING PIN FOR MIXO
1 : $1.8
50 : $1.62
100 : $1.53
250 : $1.48
500 : $1.43
28
RFC-1326

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG, BNC JACK, RG-59B/U CBL,10FT.,BLACK, UL STDS, NON BOOTED
1 : $6.29
13
RT-120E-R+FC015

PATLITE Corporation REVOLVING LIGHT, 162MM, 32 SOUND HORN, 105DB, 4 CHANNEL, 120VAC, BEIGE, RED
1 : $472.62
7
RFC-2215

Quest Technology International Inc CABLE ASSEMBLY, UHF PLUG X2, RG-58A/U CBL, 7FT.
1 : $18.8
5
RFC-1813

Quest Technology International Inc CABLE ASSEMBLY, N PLUG X2, RG-58A/U CBL, 36"
1 : $10.7
2
RT-24E-R+FC015

PATLITE Corporation ROTATING BEACON WITH 8-CHANNEL ALARM WITH 32 PRE-PROGRAMMED SOUNDS; RED
1 : $472.62
2
RFC-1533

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-58C/U CBL, 36", NON BOOTED
1 : $6.15
1
RFC-1112

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG X2, RG-58A/U CBL, 24", BLACK, UL STDS, NON BOOTED
1 : $4.95
1
RFC-1114

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG X2, RG-58A/U CBL, 5FT., BLACK, UL STDS, NON BOOTED
1 : $5.58
1
DGRF-C-GF-25-50-P

Festo GUIDED ACTUATOR
1 : $535.72
1
CAS17C471JARFC

KEMET Corporation CAPACITOR, FILM, SFTY 1808 470PF X1 250 / Y2 250 X7R, REEL
RoHS : Compliant
1,000 : $0.81
2,000 : $0.79
0
ROCKER VVE OR FCC00-000

Carling Technologies HARDWARE, V-SERIES ROCKER SWITCH
100 : $2.33
0
ROCKER VVE OR FCY00-000

Carling Technologies HARDWARE, V-SERIES ROCKER SWITCH
100 : $2.33
0
GRFC207D-35MM (PER.GRFC207)

PEER Bearing Company PEER MOUNTED COMPONENTS (MC)
1 : $56.15
10 : $53.34
0

STMicroelectronics
SPSGRFC-868

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $17.49
10 : $15.71
25 : $14.47
100 : $13.38
288 : $12.76
24
SPSGRFC-915

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $17.52
10 : $16.11
25 : $15.45
100 : $13.61
288 : $12.94
0
SPSGRFC-433

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $11.02
10 : $10.3
25 : $10.23
50 : $10.23
100 : $10.07
250 : $9.9
500 : $9.74
0

Microchip Technology Inc
INTRFCEV

Microchip Technology Inc Power Supply and Interface Noise Board, Projected EOL:
1 : $83.48
3
MRFC544

Microchip Technology Inc 200MHZ, CW, 25V, NPN Power Transistor, DIE, Projected EOL: 2051-10-27 - Contact for Pricing
0
MRFC545

Microchip Technology Inc 200MHZ, CW, 25V, PNP Power Transistor, DIE, Projected EOL: 2051-10-27 - Contact for Pricing
0

Bisco Industries
MS28774-446 - SCARF CUT

MS O-RINGS
39
RFCAERNFTF

MISC. INDUSTRIAL CONNECTORS
2
MIL-S-22473 SURF COND

Military Specifications
1
Z-RFC-P30

MISCELLANEOUS
1

Onlinecomponents.com
RFC-1414

Quest Technology International Inc Cable Assembly, TNC Plug x2, RG-58A/U Cbl, 5ft. | Quest Technology International Inc. RFC-1414
RoHS : Compliant
100 : $7.79
50 : $7.87
25 : $7.95
10 : $8.03
0
RFC-2134

Quest Technology International Inc
RoHS : Compliant
100 : $6.44
50 : $6.51
25 : $6.57
20 : $6.64
0
RFC-1122

Quest Technology International Inc Cable Assembly, BNC Plug x2, RG-59B/U Cbl, 24", Black, UL Stds, Non Booted | Quest Technology International Inc....
RoHS : Compliant
100 : $4.896
50 : $4.946
25 : $4.996
20 : $5.046
0
RFC-1214

Quest Technology International Inc Cable Assembly, BNC Plug x2, Right Angle, RG-58A/U Cbl, 5ft., Black, UL Stds | Quest Technology International Inc....
RoHS : Compliant
100 : $6.39
50 : $6.45
25 : $6.52
20 : $6.59
0
RFC-1935

Quest Technology International Inc
RoHS : Compliant
100 : $12.71
50 : $12.84
25 : $12.97
10 : $13.1
0
RFC-2212

Quest Technology International Inc Cable Assembly, UHF Plug x2, RG-58A/U Cbl, 24", Non Booted | Quest Technology International Inc. RFC-2212
RoHS : Compliant
100 : $6.55
50 : $6.61
25 : $6.68
20 : $6.75
0
RFC-1121

Quest Technology International Inc Cable Assembly, BNC Plug x2, RG-59B/U Cbl, 12", Black, UL Stds, Non Booted | Quest Technology International Inc....
RoHS : Compliant
100 : $4.61
50 : $4.657
25 : $4.704
20 : $4.752
0
RFC-1531

Quest Technology International Inc Cable Assembly, SMA Plug x2, RG-58C/U Cbl, 12", Non Booted | Quest Technology International Inc. RFC-1531
RoHS : Compliant
500 : $20.96
250 : $21.28
100 : $21.86
50 : $22.8
25 : $23.82
10 : $24.55
1 : $27.52
0
RFC-1811

Quest Technology International Inc Cable Assembly, N Plug x2, RG-58A/U Cbl, 12" | Quest Technology International Inc. RFC-1811
RoHS : Compliant
100 : $7.09
50 : $7.16
25 : $7.23
10 : $7.31
0
RFC-1225

Quest Technology International Inc Cable Assembly, BNC Plug x2, Right Angle, RG-59B/U Cbl, 7ft., Black, UL Stds | Quest Technology International Inc....
RoHS : Compliant
100 : $6.96
50 : $7.03
25 : $7.1
10 : $7.17
0
RFC-1221

Quest Technology International Inc Cable Assembly, BNC Plug x2, Right Angle, RG-59B/U Cbl, 12", Black, UL Stds, Non Booted | Quest Technology...
RoHS : Compliant
100 : $5.1
50 : $5.16
25 : $5.21
20 : $5.26
0
RFC-2131

Quest Technology International Inc Cable Assy; 12 in.; RG-58C/U
RoHS : Compliant
100 : $5.1
50 : $5.16
25 : $5.21
20 : $5.26
0
RFC-2135

Quest Technology International Inc Cable Assy; 7 ft.; RG-58C/U
RoHS : Compliant
100 : $7.01
50 : $7.08
25 : $7.16
10 : $7.23
0
RFC-2214

Quest Technology International Inc Cable Assembly, UHF Plug x2, RG-58A/U Cbl, 5ft. | Quest Technology International Inc. RFC-2214
RoHS : Compliant
100 : $7.64
50 : $7.71
25 : $7.79
10 : $7.87
0
RFC-1216

Quest Technology International Inc Cable Assembly, BNC Plug x2, Right Angle, RG-58A/U Cbl, 10ft., Black, UL Stds | Quest Technology International Inc....
RoHS : Compliant
100 : $7.58
50 : $7.66
25 : $7.74
10 : $7.82
0

Rochester Electronics
NCP458RFCT2G

onsemi Power Distribution Switch General Purpose N-Channel 1 OUT High Side 8-BGA T/R
RoHS : Compliant
100,000 : $0.2211
10,000 : $0.2639
1,000 : $0.296
500 : $0.3209
100 : $0.3566
16,835
NCP392CRFCCT1G

onsemi Specialized Power Management Overvoltage Protection Controller 12-BGA T/R
RoHS : Compliant
100,000 : $0.3474
10,000 : $0.4146
1,000 : $0.465
500 : $0.5043
100 : $0.5603
219,000
NCP456RFCCT2G

onsemi Power Distribution Switch General Purpose N-Channel 1 OUT High Side 6-BGA T/R
RoHS : Compliant
100,000 : $0.206
10,000 : $0.2459
1,000 : $0.2758
500 : $0.2991
100 : $0.3323
21,000
NCP392ARFCCT1G

onsemi Power Distribution Switch General Purpose N-Channel 1 12-BGA T/R
RoHS : Compliant
100,000 : $0.3474
10,000 : $0.4146
1,000 : $0.465
500 : $0.5043
100 : $0.5603
1,157,125
NCP392DRFCCT1G

onsemi Specialized Power Management Overvoltage Protection Controller 12-BGA T/R
RoHS : Compliant
100,000 : $0.344
10,000 : $0.4106
1,000 : $0.4605
500 : $0.4993
100 : $0.5548
93,708
AUIRFC8407TR

Infineon Technologies AG MOSFET N-Channel 306A Die
RoHS : Not Compliant
100,000 : $0.4095
10,000 : $0.4888
1,000 : $0.5482
500 : $0.5944
100 : $0.6605
116,606
DDB2U60N12W3RFC39BPSA1

Infineon Technologies AG IGBT MOD 950V 135A 20mW Tray
RoHS : Compliant
1,000 : $126.47
500 : $130.79
100 : $135.1
25 : $139.41
1 : $143.72
568
DDB2U80N12W3RFC39BPSA1

Infineon Technologies AG DDB2U80N12W3RFC39BPSA1
RoHS : Compliant
1,000 : $123.81
500 : $128.03
100 : $132.25
25 : $136.47
1 : $140.69
0
AUIRFC8407TR

International Rectifier MOSFET N-Channel 306A Die
RoHS : Not Compliant
100,000 : $0.4095
10,000 : $0.4888
1,000 : $0.5482
500 : $0.5944
100 : $0.6605
306,276
ISL9000IRFCZ

Intersil Corporation IC VOLT REG Fixed 2 REG 1.8V, 2.5V 300mA, 300mA 10-SON
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
19
ISL9014IRFCZ

Intersil Corporation IC VOLT REG Fixed 2 REG 2.5V, 1.8V 300mA 10-SON Tube
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
42
ISL9014IRFCZ-T

Intersil Corporation IC VOLT REG Fixed 2 REG 2.5V, 1.8V 300mA 10-SON T/R
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
5,950
DF2646RFC20J

Renesas Electronics Corporation IC MCU H8S/2600 16Bit 1 Core FLASH 128kB (128k x 8) 20MHz 144-QFP
RoHS : Compliant
10,000 : $22.49
1,000 : $23.89
500 : $25.3
100 : $26.7
25 : $28.11
13
M3030RFCPGP#U5

Renesas Electronics Corporation IC MCU 16BIT 128KB FLASH 48LQFP
RoHS : Compliant
10,000 : $7.15
1,000 : $7.6
500 : $8.05
100 : $8.49
25 : $8.94
1,734

Sager
HBL2172RFC1BK

Hubbell Incorporated RF CTRL HGR, SPLT CIRC, 15A, 5-15R, BK
1 : $190.15
4 : $182.33
0
HBL2172RFC1LA

Hubbell Incorporated RF CTRL HGR, SPLT CIRC, 15A, 5-15R, LA
1 : $190.15
4 : $182.33
0
HBL5262RFC1

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 15A, 5-15R, BR
1 : $158.72
5 : $152.2
0
HBL5362RFC2GY

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 20A, 5-20R, GY
1 : $158.72
5 : $152.2
0
HSCP-HRFCJ-1AS(60)

Hirose Electric Co Ltd Fiber Optic Connectors ADAPTER RCPT SC-FC
0
PSR-FC100

IDEC Corporation DIN Rail Power Supplies
0
HRFC-P6-H(60)

Hirose Electric Co Ltd Fiber Optic Connectors
0
HBL2182RFC1GN

Hubbell Incorporated RF CTRL HGR, SPLT CIRC, 20A, 5-20R, GN
1 : $194.85
4 : $186.85
0
HBL5362RFC1I

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, IV
1 : $166.57
5 : $159.73
0
HBL2182RFC2I

Hubbell Incorporated RF CTRL HGR, FULL CTRLD, 20A, 5-20R, IV
1 : $190.15
4 : $182.33
0
HBL5362RFC1GN

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, GN
1 : $166.57
5 : $159.73
0
274LRF-CS703

ABB Group Thomas & Betts
1 : $38.06
5 : $35.14
13 : $33.59
26 : $32.63
53 : $31.72
105 : $30.44
0
A2/0-12RF-C

Panduit Corp Terminals Battery Cable Lug, 2 AWG, 1/4 Stud, 45
1 : $5.6
29 : $5.34
72 : $4.82
144 : $4.45
288 : $4.28
576 : $4.28
0
HBL5262RFC2BK

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 15A, 5-15R, BK
1 : $160.75
3 : $151.57
5 : $145.33
0
HBL5262RFC2LA

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 15A, 5-15R, LA
1 : $160.75
3 : $151.57
5 : $145.33
0

TME
CAS21C472JARFC

YAGEO Corporation Capacitor: ceramic; 4.7nF; 250VAC; X7R; ±5%; SMD; 2220; Thk: 2.794mm
500 : $1.61
500
CAS26C152KARFC

YAGEO Corporation Capacitor: ceramic; 1.5nF; 250VAC; X7R; ±10%; SMD; 2211; Thk: 2.794mm
500 : $0.82
500
CAS17C681KARFC

KEMET Corporation Capacitor: ceramic; X1/Y2; 680pF; 250VAC; X7R; ±10%; SMD; 1808
RoHS : Compliant
1,000 : $0.54
500 : $0.546
100 : $0.642
50 : $0.697
10 : $0.87
1 : $1.31
270
CRF CX D

ILME UK Ltd Keying screw; female
500 : $0.619
100 : $0.732
10 : $0.896
1 : $1.07
267
RFCT-N-CAP-GS-2

Global Connector Technology Protection cover; IP67; Application: N socket
RoHS : Compliant
500 : $3.42
200 : $3.53
100 : $3.65
50 : $3.78
25 : $3.92
10 : $4.1
1 : $4.81
231
RF-C37P0-URF-AR

Shenzhen Refond Optoelect LED; UV-C; 120°; 350mA; 3.8W; λd: 270÷280nm; 4.5÷7.5VDC; SMD
25 : $16.0
5 : $17.6
1 : $19.2
7
RFC570B-AIW-DNS

Raystar Optronics Inc Display: TFT; 5.7"; 320x240; Illumin: LED; Dim: 160x109x9.8mm; RGB
5 : $42.74
3 : $43.2
1 : $44.4
5
RFC570P-EIW-DBG

Raystar Optronics Inc Display: TFT; 5.7"; 320x240; Illumin: LED; RGB; 320÷400cd/m2
3 : $38.36
1 : $45.2
2
CAS17C102KARFC

KEMET Corporation Capacitor: ceramic; X1/Y2; 1nF; 250VAC; X7R; ±10%; SMD; 1808
RoHS : Compliant
5,000 : $0.569
3,000 : $0.577
2,000 : $0.592
1,000 : $0.614
1 : $1.54
0
CAS21C472KARFC

KEMET Corporation Capacitor: ceramic; X1/Y2; 4.7nF; 250VAC; X7R; ±10%; SMD; 2220
RoHS : Compliant
2,500 : $1.17
1,000 : $1.24
500 : $1.29
250 : $1.37
100 : $1.5
50 : $1.64
10 : $2.06
5 : $2.29
1 : $2.82
0
DDB2U60N12W3RFC39B

Infineon Technologies AG Bridge rectifier: single-phase
8 : $188.05
0
RF-CC1101-868

Radiocontrolli Module: RF; 868MHz; SPI; -112dBm; 1.8÷3.6VDC; 12dBm; SMD; 16x9mm
25 : $13.35
5 : $15.58
1 : $16.36
0
RF-CC1310-AT

Radiocontrolli Module: RF; 868/915MHz; SPI; -124dBm; 1.8÷3.8VDC; 14dBm; SMD; SMA
25 : $10.85
5 : $12.46
1 : $13.35
0
RF-CC1310-AT-EV

Radiocontrolli Dev.kit: RF; Comp: CC1101; 1.8÷3.8VDC
1 : $26.15
0
RF-CC1310-AT-EV

Radiocontrolli Dev.kit: RF; Comp: CC1310; 5VDC; prototype board
1 : $80.67
0

Ameya Holding Limited
RFC02MM2STR

ROHM Semiconductor 超快速恢复二极管
RoHS : Compliant
1 : $0.46
10 : $0.352
100 : $0.22
500 : $0.15
1,000 : $0.116
3,000 : $0.104
65

ComSIT USA
ADM809XCSURFCAM

Analog Devices Inc Electronic Component
RoHS : Not Compliant
20,000
MFR3100RFC

TT Electronics Welwyn Components Fixed Resistor, Metal Film, 0.4W, 100ohm, 200V, 1% +/-Tol, 50ppm/Cel, Through Hole Mount
RoHS : Compliant
15,000
3301C44RRFCD1T1U1CHAM

Everlight Electronics Co Ltd DIA 3 PIRANHA LED Single Color LED, Red, Water Clear Colorless, T-1, 3mm
RoHS : Compliant
5,360
MFR3422RFC

TT Electronics Welwyn Components Fixed Resistor, Metal Film, 0.4W, 422ohm, 200V, 1% +/-Tol, 50ppm/Cel, Through Hole Mount
RoHS : Compliant
5,000
SAKC164CW4RFCA

Infineon Technologies AG Electronic Component
RoHS : Compliant
4,687
SAKC164SM4RFCA

Infineon Technologies AG 16-BIT SINGLE-CHIP MICROCONTROL LER Microcontroller, CMOS
RoHS : Compliant
1,900
AUIRFC3805TR

International Rectifier Electronic Component
RoHS : Not Compliant
1,000

GLYN GmbH & Co. KG
CAB-GRE-RFC7_KABEL_Y

Great Ideal Co Ltd IDC 2.54-2*5P TO 51021-0800 & A1255H-06P Wireÿ:U
2

Interstate Connecting Components
MFM062RFC009

Amphenol PCD FIBRE
0
PKT06RFC32-17P

Amphenol Aerospace HIGH PWR THRD COUPL STR PLUG ELECT CRIMP 4#4 HIGH CRNT PIN
0
PKT06RFC32-15P

Amphenol Aerospace 5015 POWER THRD COUPLING PLUG CRIMP 2#0 6#12 PIN
0
PKB06RFC20-2R

Amphenol Aerospace
0
MFM002RFC

Amphenol PCD FIBRE
0
MFM062RFC

Amphenol PCD FIBRE
0
PKB06RFC22-22R

Amphenol Aerospace 5015 HIGH PWR W/ BAYONET COUP STR PLUG 4#8 RADSOK ENP
0
PKT06RFC36-3P

Amphenol Aerospace
0
PKT02RFC22-22R

Amphenol Aerospace 5015 HIGH POWER BX MNT RCP 4#8 RADSOK ENP
0
PKT02RFC32-01T

Amphenol Aerospace 91-716677-01CT
0
PKT06RFC24-10TW

Amphenol Aerospace PWR 5015 THRD COUP STR PLG 7#8 SKT W ENP
0
MFM072RFC009

Amphenol PCD FIBRE
0
MFM072RFC011

Amphenol PCD FIBRE
0
PKT06RFC36-5P

Amphenol Aerospace
0
PKT09RFC32-17R

Amphenol Aerospace
0

PEI Genesis
PKB05RFC24-12PX

Amphenol Corporation
1 : $0.0
10 : $0.0
25 : $0.0
50 : $0.0
100 : $0.0
0
PKB05RFC24-12PY

Amphenol Corporation
1 : $0.0
10 : $0.0
25 : $0.0
50 : $0.0
100 : $0.0
0

Richardson RFPD
P2RFC-2275-540

RF Industries CBL ASSY; 4.3/10 MALE TO 4.3/10 MALE; TFT-402LF; P
RoHS : Not Compliant
19 : $154.45
0
INTRFCEV

Microchip Technology Inc Power Supply And Interface Noise Board
RoHS : Compliant
19 : $95.3
0
P2RFC-2275-420

RF Industries CBL ASSY; 4.3/10 MALE TO 4.3/10 MALE; TFT-402LF; P
RoHS : Not Compliant
0

Chip 1 Exchange
D12-100-715R-FCS

Vishay Intertechnologies INSTOCK
220,000
D12-100-768R-FCS

Vishay Intertechnologies INSTOCK
170,000
D25820RFCS

Vishay Roederstein INSTOCK
5,000
D12931RFCS

INSTOCK
5,000
D25210RFCS

Vishay Roederstein INSTOCK
5,000
D25210RFCS

Vishay Roederstein INSTOCK
5,000
D25732RFCS

Vishay Roederstein INSTOCK
5,000
A38499RFCS

INSTOCK
5,000
D25511RFCS-1

INSTOCK
5,000
D12274RFCS

Vishay Roederstein INSTOCK
4,900
D25604RFC

Vishay Roederstein INSTOCK
3,345
D12261RFCS

INSTOCK
2,970
D25215RFCS

Vishay Roederstein INSTOCK
2,715
D25649RFCS

Vishay Roederstein INSTOCK
2,170
RFC16474F

Dubilier INSTOCK
1,500

Avnet Abacus
H830RFCA

TE Connectivity Resistor 30 Ohm 1 250 mW Axial Leaded Metal Film Precision (Alt: 1-1879625-2)
RoHS : Compliant
0
H4P18RFCA

TE Connectivity Res Metal Film 18 Ohm 1 1W 50ppmC Conformal AXL ThruHole Bandoliered (Alt: 1879621-7)
RoHS : Compliant
0
228ADVARFCRC

CTS Corporation (Alt: 228ADVARFCRC)
RoHS : Compliant
0
228ADS1ARFCRE

CTS Corporation (Alt: 228ADS1ARFCRE)
RoHS : Compliant
0
228ADS2ARFCAA

CTS Corporation (Alt: 228ADS2ARFCAA)
RoHS : Compliant
0
228ADVARFCBBA

CTS Corporation (Alt: 228ADVARFCBBA)
RoHS : Compliant
0
228ADVARFCMSC

CTS Corporation (Alt: 228ADVARFCMSC)
RoHS : Compliant
0
228CMVARFCRBR

CTS Corporation - Tape and Reel (Alt: 228CMVARFCRBR)
RoHS : Compliant
0
228AMVARFCRBR

CTS Corporation (Alt: 228AMVARFCRBR)
RoHS : Compliant
0
228CDVARFCMBB

CTS Corporation (Alt: 228CDVARFCMBB)
RoHS : Compliant
0
228ADS2ARFCMBC

CTS Corporation (Alt: 228ADS2ARFCMBC)
RoHS : Compliant
0
CAS17C471JARFC

KEMET Corporation Ceramic Suppression Capacitor 470 pF 5 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C471JARFC)
RoHS : Compliant
0
CAS17C821MARFC

KEMET Corporation Ceramic Suppression Capacitor 820 pF 20 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C821MARFC)
RoHS : Compliant
0
CAS18C681JARFC

KEMET Corporation Ceramic Suppression Capacitor 680 pF 5 X1 Y2 250 VAC 250 VAC 1812 4532 Metric (Alt: CAS18C681JARFC)
RoHS : Compliant
0
228ADS1ARFCMBB

CTS Corporation (Alt: 228ADS1ARFCMBB)
RoHS : Compliant
0

Avnet Asia
QTLP650C4TR/FC15-21SYGC/S530-E2/TR8

Everlight Electronics Co Ltd (Alt: QTLP650C4TR/FC15-21SYGC/S530-E2/TR8)
RoHS : Compliant
0
CAS17C102MARFC

KEMET Corporation (Alt: CAS17C102MARFC)
RoHS : Compliant
0
R5F10RFCAFP#10

Renesas Electronics Corporation Microcontroller 16-Bit RL78 CISC 32KB Flash 44-Pin LQFP (Alt: R5F10RFCAFP#10)
RoHS : Compliant
0
CAS17C102KARFC

KEMET Corporation Ceramic Suppression Capacitor, 1000 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] (Alt: CAS17C102KARFC)
RoHS : Compliant
0
TLP785(GR,F(C

Toshiba America Electronic Components (Alt: TLP785(GR,F(C)
RoHS : Compliant
0
CAS17C331KARFC

KEMET Corporation Ceramic Suppression Capacitor, 330 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] (Alt: CAS17C331KARFC)
RoHS : Compliant
50,000 : $0.50863
25,000 : $0.52167
10,000 : $0.53539
5,000 : $0.54986
3,000 : $0.5574
2,000 : $0.56514
1,000 : $0.5731
0
NCP456RFCCT2G

onsemi Load Switch, 2 A Single, For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
R5F10RFCAFP#50

Renesas Electronics Corporation MCU 16-Bit RL78 CISC 32KB Flash 1.6V to 5.5V 44-Pin LQFP Tray (Alt: R5F10RFCAFP#50)
RoHS : Compliant
0
CAS18C102KARFC

KEMET Corporation (Alt: CAS18C102KARFC)
RoHS : Compliant
0
CAS26C222KARFC

KEMET Corporation Ceramic Suppression Capacitor, 2200 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2211 [5728 Metric] (Alt: CAS26C222KARFC)
RoHS : Compliant
0
CAS21C472KARFC

KEMET Corporation Ceramic Suppression Capacitor, 4700 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2220 [5650 Metric] (Alt: CAS21C472KARFC)
RoHS : Compliant
0
RFCM3328TR13

Qorvo (Alt: RFCM3328TR13)
RoHS : Compliant
0
TC75W71FU,RF(CB

Toshiba America Electronic Components TOSTC75W71FU,RF(CB CMOS LINEAR IC (Alt: TC75W71FU,RF(CB)
RoHS : Compliant
0
RFCM3327TR13

Qorvo (Alt: RFCM3327TR13)
RoHS : Compliant
0

Avnet Silica
1320XRFC

NXP Semiconductors Daughter Card RF Zigbee Communication Networking MC9S08 (Alt: 1320XRFC)
RoHS : Compliant
0
SRFC025-200

Antenova M2M AVIA 3G FLEXIBLE ANTENNA 200mm cable (Alt: SRFC025-200)
RoHS : Compliant
0
SRFC025-100

Antenova M2M AVIA 3G FLEXIBLE ANTENNA 100mm cable (Alt: SRFC025-100)
RoHS : Compliant
0
SRFC015-100

Antenova M2M Zhengi flexible antenna 100mm cable Ipex Cellular 3G 4G and LTE (Alt: SRFC015-100)
RoHS : Compliant
0
RFCM3328TR13

Qorvo (Alt: RFCM3328TR13)
RoHS : Compliant
0
NCP456RFCCT2G

onsemi Load Switch 2 A Single For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
RFC02MM2STFTR

ROHM Semiconductor Super Fast Recovery Diode 200V 500mA 2Pin SOD123L TR (Alt: RFC02MM2STFTR)
RoHS : Compliant
0
STM32WC-RFCKIT

STMicroelectronics Development Kit For STM32W RF Wireless Control (Alt: STM32WC-RFCKIT)
RoHS : Compliant
0
R5F10RFCGFP#50

Renesas Electronics Corporation (Alt: R5F10RFCGFP#50)
RoHS : Compliant
0
M3030RFCPGP#33

Renesas Electronics Corporation 16BIT MCU M16C30P (Alt: M3030RFCPGP#33)
RoHS : Compliant
0
R5F10RFCAFP#10

Renesas Electronics Corporation (Alt: R5F10RFCAFP#10)
RoHS : Compliant
0
R5F10RFCAFP#50

Renesas Electronics Corporation (Alt: R5F10RFCAFP#50)
RoHS : Compliant
0

Component Electronics, Inc
D11010RFCS

Vishay Intertechnologies IN STOCK SHIP TODAY
1,000 : $0.08
100 : $0.09
1 : $0.12
3,000
RFC-8716-60

RF CONN IN STOCK SHIP TODAY
1,000 : $17.5
100 : $20.19
1 : $26.92
117
RFC-8714-60

RF CONN IN STOCK SHIP TODAY
1,000 : $12.5
100 : $14.42
1 : $19.23
46
RFC-8715-14

RF CONN IN STOCK SHIP TODAY
1,000 : $10.0
100 : $11.54
1 : $15.38
46
RFC1010B-104KE

Coilcraft Inc IN STOCK SHIP TODAY
RoHS : Compliant
1,000 : $1.0
100 : $1.15
1 : $1.54
10
SR-FC-HUB

IN STOCK SHIP TODAY
5
194R-FCA2

AB Connectors Ltd IN STOCK SHIP TODAY
1,000 : $25.0
100 : $28.85
1 : $38.46
3

EBV Elektronik
TLP785F(GR,F(C

Toshiba America Electronic Components Optocoupler 1CH Open Collector 5000Vrms 4Pin DIP Tube (Alt: TLP785F(GR,F(C)
RoHS : Compliant
10,600
TLP785(GR,F(C

Toshiba America Electronic Components Optocoupler DCIN 1CH Transistor DCOUT 4Pin DIP (Alt: TLP785(GR,F(C)
RoHS : Compliant
3,400
TLP785(D4-GR,F(C

Toshiba America Electronic Components Optocoupler DCIN 1CH DCOUT 4Pin PDIP SMD (Alt: TLP785(D4-GR,F(C)
RoHS : Compliant
1,600
NCP456RFCCT2G

onsemi Load Switch 2 A Single For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
M3030RFCPGP#35

Renesas Electronics Corporation 16BIT MCU M16C30P (Alt: M3030RFCPGP#35)
RoHS : Compliant
0
CL8068404069606S RFCR

Intel Corporation Intel Core i59300H Processor 8M Cache up to 410 GHz FCBGA14F Tray (Alt: 999CXR)
RoHS : Compliant
0
CL8068404069418S RFCP

Intel Corporation Intel Core i79750H Processor 12M Cache up to 450 GHz FCBGA14F Tray (Alt: 999CXN)
RoHS : Compliant
0

Flip Electronics
R5F10RFCAFP#10

Renesas Electronics Corporation Stock
RoHS : Compliant
3,840
R5F10RFCAFP#30

Renesas Electronics Corporation Stock
RoHS : Compliant
1,221

Master Electronics
MFR3-620RFC

TT Electronics Welwyn Components Res Metal Film 620 Ohm 1% 0.4W ±50ppm/C Conformal Coated AXL Ammo
RoHS : Compliant
500,000 : $0.0135
250,000 : $0.0135
150,000 : $0.0137
100,000 : $0.0138
50,000 : $0.0141
25,000 : $0.0142
5,000 : $0.0149
20,000
H8820RFCA

TE Connectivity H8 820R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.314
10,000 : $0.3148
7,500 : $0.3367
5,000 : $0.3376
2,500 : $0.3548
1,000 : $0.365
500 : $0.3736
250 : $0.3797
250
H4P18RFCA

TE Connectivity H4P 18R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H830RFCA

TE Connectivity H8 30R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
SRFC5JUNT4

Tripp Lite SRFC5JUNT4
RoHS : Compliant
100 : $66.1
50 : $66.99
20 : $68.82
10 : $72.81
5 : $74.98
1 : $81.03
0
ROCKER-VVE-OR-FCC00-000

Carling Technologies V-SERIES ROCKER SWITCH
RoHS : Compliant
10,000 : $1.54
7,500 : $1.55
5,000 : $1.56
2,500 : $1.6
1,000 : $1.64
500 : $1.74
300 : $1.79
100 : $2.3
0
ROCKER-VVE-OR-FCY00-000

Carling Technologies V-SERIES ROCKER SWITCH
RoHS : Compliant
10,000 : $1.54
7,500 : $1.55
5,000 : $1.56
2,500 : $1.6
1,000 : $1.64
500 : $1.74
300 : $1.79
100 : $2.3
0
H4P11RFCA

TE Connectivity H4P 11R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H815RFCA

TE Connectivity H8 15R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
SRFC5RAMP

Tripp Lite SRFC5RAMP
RoHS : Compliant
100 : $86.62
50 : $87.77
20 : $90.18
10 : $95.41
5 : $98.25
1 : $106.18
0
H4P13RFCA

TE Connectivity H4P 13R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H4P620RFCA

TE Connectivity H4P 620R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H8150RFCA

TE Connectivity H8 150R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H862RFCA

TE Connectivity H8 62R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H8866RFCA

TE Connectivity H8 866R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0

Venkel Ltd.
RFCA1206K1T

VENKEL LTD RF Ceramic Antenna;1206;5GHz
RoHS : Not Compliant
0
RFCA1206E0T

VENKEL LTD RF Ceramic Antenna;1206;1.575GHz
RoHS : Not Compliant
0
RFCA0805A3T

VENKEL LTD RF Ceramic Antenna;0805;2.4GHz
RoHS : Not Compliant
0
RFCA1206AAT

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA1206A1T

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA3224YAT

VENKEL LTD RF Ceramic Antenna;3224;6.5GHz
RoHS : Not Compliant
0
RFCA1206Y1T

VENKEL LTD RF Ceramic Antenna;1206;7.37GHz
RoHS : Not Compliant
0
RFCA1206A5T

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA0805A0T

VENKEL LTD RF Ceramic Antenna;0805;2.45GHz
RoHS : Not Compliant
0
RFCA0402A1T

VENKEL LTD RF Ceramic Antenna;0402;2.45GHz
RoHS : Not Compliant
0
RFCA3708A0T

VENKEL LTD RF Ceramic Antenna;3708;2.4GHz
RoHS : Not Compliant
0

Vyrian
CAS17C102MARFC

KEMET Corporation Ceramic Capacitor, Multilayer, Ceramic, 20% +Tol, 20% -Tol, X7R, 15% TC, 0.001uF, Surface Mount, 1808
15,432
RFC0807BV-105KE

Coilcraft Inc General Purpose Inductor, 1000uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
15,002
IRFC7314B

Infineon Technologies AG
12,015
NCP458RFCCT2G

onsemi Buffer/Inverter Based Peripheral Driver, 1 Driver, PBGA8
RoHS : Compliant
11,589
RFC0807BV-154KE

Coilcraft Inc General Purpose Inductor, 150uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
9,964
IRFC7416B

Infineon Technologies AG
9,028
SPSGRFC-868

STMicroelectronics
RoHS : Compliant
8,992
STM32W-RFCKIT

STMicroelectronics
8,419
SPSGRFC-433

STMicroelectronics
RoHS : Compliant
5,784
VT451RFCR-ADJ

Analog Devices Inc
5,261
STM32WC-RFCKIT

STMicroelectronics
5,121
XQVU095-2RFC1517E

AMD Xilinx Field Programmable Gate Array, 1176000-Cell, PBGA1517
RoHS : Not Compliant
1,987
XQVU065-2RFC1517I

AMD Xilinx Field Programmable Gate Array, 783300-Cell, PBGA1517
RoHS : Not Compliant
1,605
XQVU095-1RFC1517M

AMD Xilinx Field Programmable Gate Array, 1176000-Cell, PBGA1517
RoHS : Not Compliant
1,593
SPSGRFC-915

STMicroelectronics Telecom Circuit
RoHS : Compliant
402

Win Source Electronics
RFCMF1220100M3T

Walsin Technology Corporation CMC 300MA 2LN 80 OHM SMD
RoHS : Compliant
1,440 : $0.2084
1,080 : $0.2325
835 : $0.2405
605 : $0.2485
390 : $0.2565
160 : $0.3126
51,804
HI3516ARFCV200

HiSilicon Technologies Co Ltd
5 : $93.4268
4 : $104.2067
3 : $107.8001
2 : $111.3934
1 : $114.9867
355
HI3521RFCV100

HiSilicon Technologies Co Ltd
10 : $33.116
7 : $36.937
6 : $38.2107
4 : $39.4844
3 : $40.7581
2 : $49.6739
268

Link URL



Does ALLDATASHEET help your business so far?  [ DONATE ]  

About Alldatasheet   |   Advertisement   |   Contact us   |   Privacy Policy   |   Link to Datasheet    |   Link Exchange   |   Manufacturer List
All Rights Reserved짤Alldatasheet.com


Mirror Sites
English : Alldatasheet.com  |   English : Alldatasheet.net  |   Chinese : Alldatasheetcn.com  |   German : Alldatasheetde.com  |   Japanese : Alldatasheet.jp
Russian : Alldatasheetru.com  |   Korean : Alldatasheet.co.kr  |   Spanish : Alldatasheet.es  |   French : Alldatasheet.fr  |   Italian : Alldatasheetit.com
Portuguese : Alldatasheetpt.com  |   Polish : Alldatasheet.pl  |   Vietnamese : Alldatasheet.vn
Indian : Alldatasheet.in  |   Mexican : Alldatasheet.com.mx  |   British : Alldatasheet.co.uk  |   New Zealand : Alldatasheet.co.nz
Family Site : ic2ic.com  |   icmetro.com